Beranda > Linux, Tips & Trick > install ffmpeg

install ffmpeg

FFmpeg merupakan pustaka (library) / program dalam menghandle file multimedia. FFmpeg memliki kemampuan transcoding (convert) file multimedia ke berbagai file format seperti mpeg (1,2,4), 3gp, mp3, aac, H264 dan sebagainya. FFmpeg dapat dipakai sebagai addon shared library (jika diaktifkan pada proses compile) untuk melengkapi koleksi codec pada aplikasi pemutar video semacam SMPlayer dan sebagainya. Bagaimana tertarik? Yuks install ffmpeg.

1. uninstall ffmpeg dan x264 menggunakan perintah

sudo apt-get purge ffmpeg x264 libx264-dev

2. install paket tambahan

sudo apt-get update && sudo apt-get install \
build-essential subversion git-core checkinstall \
yasm texi2html libfaac-dev libfaad-dev \
libmp3lame-dev libsdl1.2-dev libtheora-dev libx11-dev \
libxvidcore4-dev zlib1g-dev

3. download dan install x264

cd
git clone git://git.videolan.org/x264.git
cd x264
./configure
make
sudo checkinstall --fstrans=no --install=yes --pkgname=x264 \
--pkgversion "1:0.svn`date +%Y%m%d`-0.0ubuntu1" --default

4. download dan install ffmpeg

cd
svn checkout svn://svn.ffmpeg.org/ffmpeg/trunk ffmpeg
cd ffmpeg
./configure --enable-gpl --enable-nonfree --enable-pthreads \
--enable-libfaac --enable-libfaad --enable-libmp3lame \
--enable-libtheora --enable-libx264 --enable-libxvid \
--enable-x11grab --enable-shared
make
sudo checkinstall --fstrans=no --install=yes --pkgname=ffmpeg \
--pkgversion "3:0.svn`date +%Y%m%d`-12ubuntu3" --default

selesai deh selamat mencoba

untuk mentest jalankan perintah ffmpeg  jika berhasil maka muncul

FFmpeg version SVN-r20803, Copyright (c) 2000-2009 Fabrice Bellard, et al.
built on Dec 12 2009 13:26:58 with gcc 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)

jika terjadi error

ffmpeg: error while loading shared libraries: libavdevice.so.52:
cannot open shared object file: No such file or directory 

silakan merujuk ke referensi no [3]

Jika ada paket yang belum diinstall, silakan install paket yang diperlukan.
pengalaman pas ngintstallnya ada error libmp3 dan libtheora ga ketemu di repositori gw

solusi: download install dulu libmp3lame libmp3lame-dev dari situs http://debian-multimedia.org/pool/main/l/
sudo dpkg -i install libmp3lame*

serta libtheora [4] dari http://theora.org/downloads/

ekstrak file downloadnya (yang tar gz)

sudo apt-get install build-essential autoconf automake \
intltool subversion
./autogen.sh && make && sudo make install && sudo ldconfig

Referensi

1. http://www.webupd8.org/2009/08/upgrade-to-latest-ffmpeg-and-x264-in.html

2. http://linux.justinhartman.com/FFmpeg,_FFmpeg-PHP,_Lame,_Libogg,_Libvorbis,_FLVtool2,_Mplayer,_Mencoder,_AMR_Installation

3. http://ubuntuforums.org/showthread.php?t=903103

4. http://lists.xiph.org/pipermail/theora/2009-July/002569.html

Kategori:Linux, Tips & Trick Tag:, ,
  1. Belum ada komentar.
  1. No trackbacks yet.

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: